News   Oct 18, 2019
 162     0 
News   Oct 18, 2019
 220     0 
News   Oct 18, 2019
 644     1 

Forum Upgrade

Edward Skira

http://skyrisecities.com
Staff member
Member Bio
Joined
Apr 22, 2007
Messages
13,110
Reaction score
10,035
Location
Toronto
LG V20, Chrome. I am not saying that it won't scroll. You know how you can pull down the page at the top to refresh it? It won't let me do that.
response from my developer @hw621

Ah, Chrome has a pull down to refresh feature. It typically only works if you’re at the top of the page and pull down more from there though. He’s probably pulling down on the sticky header when he’s further down on the page expecting it to work, but it doesn’t work like that. Tested on Chrome on my phone and it works as expected.

So if he scrolls to the top of the page and pulls down from there to refresh it should work.
 

hw621

Senior Member
Member Bio
Joined
Jan 9, 2018
Messages
1,066
Reaction score
655
response from my developer @hw621
Thanks for the efforts. Unfortunately, I tried a few times, making sure I was not pulling the sticky header but it still does not work. The features works on other pages. It worked on the old version of the forum. It even worked for the first couple days after the upgrade and just stopped working for the last two days. Now every time I refresh the page I will have to open the menu and press the refresh button.
 

nfitz

Superstar
Member Bio
Joined
Nov 10, 2007
Messages
23,253
Reaction score
3,358
Location
Toronto
Top two will be gone when the new site launches. The third is an ad. I assume you are using an ad blocker?
Thanks.

No ad or pop-up blocker here. My setup is pretty vanilla, other than the corporate firewall. Checking IE that I seldom use - also blank. And I do keep seeing that Kings Landing add on the right-hand side in both.

I couldn't see any particular domain that was causing a problem though. Is there a URL I can check, to see if we are corporately blocking it? Though the proxy server is notorious for not liking malformed HTML ... (I do see the top ad if I remote desktop into a machine outside our firewall).

Here it is blank, but with the King's Landing ad:

1542316934355.png
 

DSC

Superstar
Member Bio
Joined
Jan 13, 2008
Messages
10,351
Reaction score
5,098
Location
St Lawrence Market Area
Though I like the overall upgrade, I wish it were still possible, after looking at a thread and using back-button to get back to previous page at the point you left it. It now always brings me back to the top of the page so I have to scroll down again to look at other threads that interest me.

I also hope progress is being made on putting back the (duplicate) navigation bar at bottom of page (as before).

thread.jpg
 
Last edited:

KevinT

Active Member
Member Bio
Joined
Mar 20, 2016
Messages
459
Reaction score
527
Location
Kitchener
I also hope progress is being made on putting back the (duplicate) navigation bar at bottom of page (as before).

View attachment 164021
I'll second that. I typically only browse the Transportation and Infrastructure forum, so being able to click that link once I got to the bottom of a thread without scrolling back up made catching up in the forum a breeze. The desktop site has it, the mobile site does not.

Overall though, very pleased with the changes and much thanks to the UT staff for all the great work!
 

KevinT

Active Member
Member Bio
Joined
Mar 20, 2016
Messages
459
Reaction score
527
Location
Kitchener
View attachment 164093

Wow, either I was blind before or that was the fastest feature request turnaround ever. Thanks UT staff!
Figured something out: As you flick and coast to scroll a thread on a mobile device, the coasting always stops at the bottom of the lower ad. If you deliberately scroll a second time, then the link to the thread's parent forum is revealed.
 

Edward Skira

http://skyrisecities.com
Staff member
Member Bio
Joined
Apr 22, 2007
Messages
13,110
Reaction score
10,035
Location
Toronto

jaybe

Active Member
Member Bio
Joined
Nov 5, 2014
Messages
205
Reaction score
455
Though I like the overall upgrade, I wish it were still possible, after looking at a thread and using back-button to get back to previous page at the point you left it. It now always brings me back to the top of the page so I have to scroll down again to look at other threads that interest me.

I also hope progress is being made on putting back the (duplicate) navigation bar at bottom of page (as before).

View attachment 164021
Hi UT.
This issue is basic web navigation that we've all become used to. Returning to the top of a forum page after reviewing a specific thread means you have to scroll down to find the next thread that may be of interest. Threads are not marked as read when using the back button, so it is a PITA to figure out where you were in the forum. The issue is more noticeable on my cell phone display because scrolling down takes more effort. Are you working on this fix?
 
Top